Llega el Jailbreak para iOS 10.2, pero sin compatibilidad para el iPhone 7

Luca Todesco activó la maquinaria ayer mismo. Era la antesala al Jailbreak para iOS 10.2. Y es el que el desarrollador italiano publicaba el código fuente de su ya conocida herramienta Yalu. Finalmente, hoy ya es posible descargar la versión de Yalu compatible iOS 10.2 (que no con iOS 10.2.1). Sin embargo, tal y como ya se atisbaba desde el pasado mes de diciembre, el iPhone 7 quedará fuera de los modelos compatibles.

La historia del Jailbreak es cuanto menos interesante. Detrás de todas y cada una de las versiones de la plataforma de software de Apple hay una incesante lucha de desarrolladores contra el departamento de ingeniería de software Apple. Y es que el Jailbreak siempre ha estado supeditado a la búsqueda de agujeros de seguridad y exploits con los que aprovecharse de los primeros. Con iOS 10 podríamos decir que Apple ha dificultado en gran medida la labor de la escena en torno al iPhone. Sin embargo, la batalla continúa y, hoy por hoy, el kernel de iOS sigue a disposición de los usuarios, al menos en parte.

Jailbreak para iOS 10.2 ya disponible con Yalu

Aunque hasta hace relativamente poco el ya popular desarrollador Luca Todesco se había mantenido en un segundo plano. Tan solo salía a la palestra para mostrar la efectividad de sus métodos y descubrimientos en torno al Jailbreak, pero no los compartía con la comunidad. Era el momento en el que grupos de desarrolladores como los de Pangu o TaiG llevaban la delantera.Jailbreak para iOS 10.2

Sin embargo, las dificultades para encontrar nuevos métodos para desarrollar y evolucionar el Jailbreak de nuevas actualizaciones de iOS ha hecho saltar a un primer plano a Todesco. Lo hizo a finales del año pasado con la liberación de Yalu para vulnerar iOS 10.1 y lo vuelve a hacer para franquear iOS 10.2. Y es que a estas horas ya está disponible la versión de su herramienta para lograr el Jailbreak para iOS 10.2.

Sin soporte para los iPhone 7 y iPhone 7 Plus

Sin embargo, la herramienta llega con restricciones y la más importante es que deja fuera a los nuevos modelos de Apple. Y es que Yalu no es compatible, por el momento, con los iPhone 7 y iPhone 7 Plus. Lo cierto es que la noticia no llega por sorpresa puesto que el propio Luca lo advertía cuando hacía oficial el Jailbreak para iOS 10.1.

Así pues, por ahora tan solo es posible el Jailbreak en la versión iOS 10.2 en los iPhone 6s (incluida la versión Plus), iPhone SE y iPad Pro. Posteriormente llegarán más modelos compatibles a la lista, pero igualmente hemos de descartar los nuevos iPhone. Como apunte, Yalu es compatible con iOS 10.2, pero hemos de recordar que Apple liberaba la semana pasada iOS 10.2.1, parche que por ahora impide el Jailbreak.

Podéis descargar Yalu 10.2 desde la página del desarrollador. Del mismo modo, es preciso indicar que se trata de un software Beta y el propio Todesco advierte de que no es estable, susceptible producir errores.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *